Fehlerbehebung

Troubleshooting Nextcloud FullTextSearch: Plugin [ingest-attachment] was built for Elasticsearch version 6.3.0 but version 6.3.2 is running

Euer Index funktioniert nicht mehr und die folgende Fehlermeldung findet sich in /var/log/elasticsearch/elasticsearch.log

Exception java.lang.IllegalArgumentException: Plugin [ingest-attachment] was built for Elasticsearch version 6.3.0 but version 6.3.2 is running

In der Nextcloud wird beim Suchen angezeigt, dass kein funktionierender Cluster aktiv ist?

Dann wurde vermutlich ein Update für Elasticsearch installiert und das ingest-Plugin ist nicht mehr kompatibel.

 


Abhilfe:

sudo /usr/share/elasticsearch/bin/elasticsearch-plugin remove ingest-attachment

und danach:

sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment

Bis dann..

2 Gedanken zu „Troubleshooting Nextcloud FullTextSearch: Plugin [ingest-attachment] was built for Elasticsearch version 6.3.0 but version 6.3.2 is running

  1. Servus und Dankeschön, das Thema ist immer noch aktuell. Meine Zammad Installation hat es nach einem Upgrade über die Update Funktion von Ubuntu von Elasticsearch Version 7.5.2 auf 7.6.0 auch zerschossen. Nach einer Neuinstallation vom Plugin und Neustart der Dienste läuft alles wieder.
    sudo /usr/share/elasticsearch/bin/elasticsearch-plugin remove ingest-attachment
    sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment
    sudo systemctl restart elasticsearch
    sudo systemctl restart zammad

    Grüße,
    Systembastler

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.